Import worklog doesn't work

Checklist before you being

  • [X] I am sure that I am already using latest version of Jira Assistant
  • [X] I had verified that, no similar issues are already reported in issue tracker
  • [X] I had tried reproducing this issue with with Web version of Jira Assistant to ensure that this issue is not recently fixed and yet to be published
  • [X] I had verified that, my query is not answered in FAQ section of website
  • [X] I had verified that, my issue is not listed as known bugs in website

How do you use Jira Assistant?

Web version

Are you using cloud version of Jira or self hosted (data center / server) of Jira.

Cloud Jira

Version of Jira Assistant


What browser are you using?


What OS are you using? You need not disclose this if you feel it is irr-relevant for your issue.


Bug Description

I tried to import my worklog today and noticed that nothing got imported. The console threw the following error:

Uncaught TypeError: e.replace is not a function
    at Object.transformHeader (290.c208ff31.chunk.js:1:665)
    at g.parse (997.d9a5e47f.chunk.js:2:15721)
    at c.parse (997.d9a5e47f.chunk.js:2:14506)
    at f.parseChunk (997.d9a5e47f.chunk.js:2:6148)
    at f._chunkLoaded (997.d9a5e47f.chunk.js:2:9548)
    at FileReader.<anonymous> (997.d9a5e47f.chunk.js:2:18643)

After some digging, I figured out that the loop that iterates through the headers (of the CSV file) and formats them also tries to format a function called "init" which leads to the crash. The line where the crash happens is

Checklist before you submit

  • [X] I have ensured not to paste any confidential information like Jira url, Mail id, etc.
  • [X] I have verified my browser console logs and added necessary details (if required)
  • [X] I have added required screenshots if the bug is related to UI (as necessary)