Worklog Report New is missing items which are shown on Worklog Report Old

Checklist before you being

  • [X] I am sure that I am already using latest version of Jira Assistant
  • [X] I had verified that, no similar issues are already reported in issue tracker
  • [X] I had tried reproducing this issue with with Web version of Jira Assistant to ensure that this issue is not recently fixed and yet to be published
  • [X] I had verified that, my query is not answered in FAQ section of website
  • [X] I had verified that, my issue is not listed as known bugs in website

How do you use Jira Assistant?

Browser extension

Are you using cloud version of Jira or self hosted (data center / server) of Jira.

Self hosted (datacenter)

Version of Jira Assistant

v2.44

What browser are you using?

Edge

What OS are you using? You need not disclose this if you feel it is irr-relevant for your issue.

Windows

Bug Description

Running the New Worklog Report for a group of users and a date range returns different results to Old Worklog report: image image image image image

Checklist before you submit

  • [X] I have ensured not to paste any confidential information like Jira url, Mail id, etc.
  • [X] I have verified my browser console logs and added necessary details (if required)
  • [X] I have added required screenshots if the bug is related to UI (as necessary)

Hi @peterwatersfis, Thank you for reporting this issue. There is already a similar issue reported #253. I will look into this issue and try to resolve it ASAP.

But for now, please let me know if the users you are viewing report for is from same timezone as yours or different timezone? Because there is a timezone configuration which could be different in both the reports. Please have a look at it once and I will try to reproduce this issue from my end.

Hi, the two users which are missing data on the New Worklog report are in the same timezone, and other users which are correctly reporting are also in this same timezone. This does look like the same issue as #253. thanks, Peter

Thank you for your reply. Similar to what I have mentioned in the other ticket, can you try to just have that single user and see what data is pulled?

You need not modify the group you had saved. From within new report you can try removing the user which is working fine and just have the user which is not working. This change in group won't be saved and so you need not reconfigure the group.

I have tried alot with cloud version of Jira and I was not able to reproduce this issue. Now I am setting up local instance of Jira to see if that helps. Will keep you posted if I find something.

Also can you verify if the user for whom worklog is not pulled in new report have logged on some issues which is having lots of worklogs, say like more than 5000 worklogs in a single issue?

Hi @peterwatersfis, I have tried alot by adding 1000's of worklog on various combinations and I couldn't reproduce the issue which you have reported. Hence I would require your help in understanding the issue:

  1. Please check with web version once and see if you were able to reproduce the issue.
  2. By any change see if you have configured Log filter or JQL filter in new worklog report. Refer to this comment for a screenshot: https://github.com/shridhar-tl/jira-assistant/issues/253#issuecomment-1372397935
  3. In old and new worklog report expand the user for whom you see the difference and try to find which issue is having this discrepancy and see if that issue is returned by Jira in network tab for new report. Also see if there are lots of worklogs (more than 5000) for that issue.
  4. Sometimes if Jira is not reindexed recently, then it randomly miss some worklog. This issue was resolved in Jira Cloud, but I haven't heard that it is resolved in Datacenter version. So you can check when was the last time Jira was reindexed.

As of now I am out of ideas on what else to try. But I will think through it while you try these options and get back to me.

Hi, I have tried to New Worklog report for the individual user and this is the result: image Comparing this to the Old Worklog report for the same user: image

I am running the Web version.

This is the Log Filter for the New Report: image The New and Old Reports have this in Jira Filter: image This is the Report Configuration for the Old report: image this is the Report Configuration for the New report: image There are not more than 5,000 report items for the user, these are the Old Report items: image There are no New report items for this user: image

I will ask our admin team when our Jira was last indexed. Thanks.

Interesting observation is that when both New and Old Worklog reports are run and the Flat (Groupable) tab is selected, the same number of rows are returned and the data for both reports is identical. New Report: image Old Report: image

Hi @peterwatersfis - Thank you providing the details.

However regarding the 5000 worklog items I did not mention in report. I asked if there are more than 5000 worklog items in Jira itself. You can check the network tab and while request goes to server for that ticket you can see max results and total results field. If that is more than 5000 then sometimes we have observed Jira randomly does not return data for certain request. Once again, most of the times such behaviors' use to be due to indexing issues only.

Next thing, if you are available for a screenshare session either tomorrow or on Sunday, you can send me an invite and I can join at that time. I would be able to join zoom call any time between 9AM IST to 10PM IST if you could send invite couple of hours in advance.

I'm usually not available for calls, but this being very critical issue and not being able to reproduce even after hours of effort from my end, would like to debug it over screenshare session if it is possible for you. Around 30 mins should do.

Hi, @shridhar-tl , we will have more that 5,000 worklog items. I do not work over the weekend so could not do a call tomorrow or Sunday, but can do a weekday. While I wait for out Jira admin team to respond to my index question I am using the Grouped Tab view of the Old Worklog data which is correct. Peter

Hi @peterwatersfis - JA v2.47 is already published and do you still see this issue with latest version of JA? I was not able to reproduce this exact issue with any kind of data, However there are multiple fixes around this use case. Hence its worth a try again.

Hi - I am running this latest version and I am getting differences between New and Old report, and I don't know which is correct:

OLD Report:

@.***

NEW Report:

@.***

Regards, Peter

From: Shridhar TL @.> Sent: 25 January 2023 02:12 To: shridhar-tl/jira-assistant @.> Cc: Waters, Peter @.>; Mention @.> Subject: Re: [shridhar-tl/jira-assistant] Worklog Report New is missing items which are shown on Worklog Report Old (Issue #254)

Hi @peterwatersfishttps://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fpeterwatersfis&data=05%7C01%7Cpeter.waters%40fisglobal.com%7Cc2c4421214bc40faad6b08dafe799ed2%7Ce3ff91d834c84b15a0b418910a6ac575%7C0%7C0%7C638102095564998436%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=kT4qXC%2BoTI87YGAgniSWzovSDFALUHzaZOezY5lampo%3D&reserved=0 - JA v2.47 is already published and do you still see this issue with latest version of JA? I was not able to reproduce this exact issue with any kind of data, However there are multiple fixes around this use case. Hence its worth a try again.

Reply to this email directly, view it on GitHubhttps://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fshridhar-tl%2Fjira-assistant%2Fissues%2F254%23issuecomment-1402992745&data=05%7C01%7Cpeter.waters%40fisglobal.com%7Cc2c4421214bc40faad6b08dafe799ed2%7Ce3ff91d834c84b15a0b418910a6ac575%7C0%7C0%7C638102095564998436%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=iGiUQ4%2FZWWJkYIZfvWtWe9U11Qb3cRBmkHFwjYF4iws%3D&reserved=0, or unsubscribehttps://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fnotifications%2Funsubscribe-auth%2FAM6W6N2ODF622IKGUKQM6ZLWUCDYXANCNFSM6AAAAAATSDH6A4&data=05%7C01%7Cpeter.waters%40fisglobal.com%7Cc2c4421214bc40faad6b08dafe799ed2%7Ce3ff91d834c84b15a0b418910a6ac575%7C0%7C0%7C638102095564998436%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=j%2BYN9A%2FZLTvCzyCpubPU3SOgjQo0jfiOgxLavAtDddE%3D&reserved=0. You are receiving this because you were mentioned.Message ID: @.@.>>

The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. FIS is a trading name of the following companies: Alphakinetic Limited (No: 06897969) | FIS Derivatives Utility Services (UK) Limited (No: 9398140) | FIS Energy Solutions Limited (No: 1889028) | FIS Global Execution Services Limited (No. 3127109) | FIS Capital Markets UK Limited (No: 982833) | FIS Treasury Centre Limited (No. 13543636) | Metavante Technologies Limited (No: 2659326) | Virtus Partners Limited (No: 06602363) | Worldpay (UK) Limited (No: 07316500 / FCA No: 530923) | Worldpay Limited (No: 03424752 / FCA No: 504504) | Worldpay AP Limited (No: 05593466 / FCA No: 502597) all registered in England & Wales with their registered office: C/O F I S Corporate Governance, The Walbrook Building, 25 Walbrook, London, EC4N 8AF. The WorldPay entities are authorised by the Financial Conduct Authority under the Payment Service Regulations 2017 for the provision of payment services. | Worldpay (UK) Limited is authorised and regulated by the Financial Conduct Authority for consumer credit activities | FIS Global Execution Services Limited is authorised and regulated by the Financial Conduct Authority | FIS Banking Solutions UK Limited (No: 3517639) and FIS Payments (UK) Limited (No: 4215488) are registered in England & Wales with their registered office at 1st Floor Tricorn House, 51-53 Hagley Road, Edgbaston, Birmingham, West Midlands, B16 8TU, United Kingdom | FIS Payments (UK) Limited is authorised and regulated by the Financial Conduct Authority; some services are covered by the Financial Ombudsman Service (in the UK). Worldpay B.V. has its registered office in Amsterdam, the Netherlands (Handelsregister KvK No: 60494344). WPBV holds a licence from and is included in the register kept by De Nederlandsche Bank, which registration can be consulted through www.dnb.nl. Calls to and from the companies may be recorded for quality purposes. | All of the named companies are ultimately owned by Fidelity National Information Services, Inc., an NYSE listed trading Company with the ticker symbol FIS.

🟢