Jira Assistant Issues

View #128 on GitHub to know more details

#128 - Google chrome has the same Data loading and no data issue

Che994 commented on Feb 28, 2020

Did anyone find solution for this? jira

adrian-moisa commented on Feb 20, 2020

v 0.95 seems to have the same problem for me. v 0.94 works fine

manasa08april commented on Feb 20, 2020

I am using the v 0.95 and facing the same issue for taking out the worklog report.

Szabotic commented on Feb 20, 2020

I'm also having the same issue on 0.95

Any advice on how to install an older version (v0.94 in this case)?

DarkSlice1 commented on Feb 20, 2020

actually tried to download v.93 and compile it with npm but the output doesn't match the readme. Manifest file is referencing files / directories that dosent exist the current folder structure.

shridhar-tl commented on Feb 20, 2020

For Firefox installing older version is possible from store itself, But for Chrome it is not possible. You will have to wait till next version gets updated. But I will try to do something temporarily and get back within couple of hours.

Sorry for the inconvenience caused. Their are multiple issues due to changes in Jira & Chromes security updates which is causing the tool to be very much unstable. Will try to solve things ASAP. This fix would be available soon for Firefox. Chrome would take some time for review for which I will try to find a workaround.

Szabotic commented on Feb 20, 2020

@shridhar-tl thanks for the attentive response! your work is most appreciated.

Che994 commented on Feb 20, 2020

@shridhar-tl Thank you for the response :) Jira assistance is awesome and that's why we are looking for immediate solution :(

shridhar-tl commented on Feb 20, 2020

Fix is now available for Firefox. For chrome no simple solution other than waiting for the review process to complete which would take another 4-5 days unfortunately.

Che994 commented on Feb 20, 2020

Thank you so much :D Its working fine on fir Firefox <3

shridhar-tl commented on Feb 20, 2020

@DarkSlice1 - Which branch have you tried to build? You should use "build_package.bat" file in package branch. Output from develop branch would be different.

CC: @Che994

craigmiller160 commented on Feb 21, 2020

v0.96 on chrome has a similar problem. My calendar will open but no worklogs will appear on it. The developer console prints out all the tickets I know I've worked on this week, so it's seeing some of the data, but it's not getting the worklog information.

I want to attach screenshots but I think my company network won't let me :(

craigmiller160 commented on Feb 21, 2020

IMPORTANT: I have the fix. I pulled down the source code and identified and fixed the problem with nothing showing up in the calendar. Because of my company's network restrictions, I am not able to create a PR to this repo, however I will be providing the code change.

The problem was utils.getUserName(). It has a convertToLower argument, however before the lower-case conversion was applied, the userName was returned. This broken other logic that depended on the name being put in lower-case.

Edit: I have gotten home to my personal laptop and I am now able to create a proper PR for my changes. Please review and merge this ASAP so that this fix can get out there.


shridhar-tl commented on Feb 28, 2020

Duplicate of #126 . Hence closing this issue. You can track for any updates through #126. Also v0.97 is already available in Firefox and should fix all the issues mentioned. For chrome it would take some time for the review to be completed by Google and hence expected date for the update to be available for chrome users is 3rd of March 2020.