Jira Assistant Issues

View #210 on GitHub to know more details

#210 - Jira Assistant no longer opens in Chrome based Vivaldi Browser

NeoMatrixJR commented on Sep 02, 2022

This started some time ago...sorry...I'm not sure exactly when. I used to use this in my Vivaldi browser, but for some time it's just been opening a blank screen. Works fine in Chrome and Edge, but Vivaldi is my daily driver. Have tested on multiple PCs.

shridhar-tl commented on Jun 07, 2022

Hi @NeoMatrixJR Thank you for reporting this issue. This addon was not tested with Vivaldi so far and so it is not a supported browser.

Still I tried to look into this issue and identified that now Vivaldi is not opening the appropriate url in window.open call. But if I debug then all works fine. Not sure what is causing this issue, but mostly it looks like issue with Vivaldi itself and not in code. So I am not sure when I would be able to solve this issue.

I would suggest using chrome, but just in case if anyone still wants to use vivaldi only, then as a temporary workaround, try bookmarking the following url and accessing it directly which works:


lbarbaglia commented on Aug 31, 2022

Basic Details:

  • 2.41
  • Firefox 104.0.1
  • Windows 11

Describe the bug When I try to open Jira Assistant from the extension button, it opens a blank page.

To Reproduce Steps to reproduce the behavior (if applicable / necessary):

  1. Click on "JA" button
  2. Blank page appears instead on the UI

Note: It's opening on the web app instead of the usual moz-extension://xxxxxxxxxxx

Screenshots image

Other details I noticed an error in the console: image

This issue appeared today, yesterday I was able to use it correctly. I was wondering if I should open an another issue since it's Firefox and not a Chrome based browser but I put it here instead.

If you need any more information, let me know.

shridhar-tl commented on Sep 02, 2022

Hi @lbarbaglia - Initially I missed your issue as it is under different title and so there was delay in resolving it. However thank you for reporting this issue with screenshot which helped me to identify and resolve the issue without much effort.

Primarily you would have switched to Web version and that is the reason it is loading Web version of JA always. You can switch back to Extension any time by once again click on Web from top right corner of the page.

Due to continuous build and publish, Web version could be unstable at times like this. But if this issue has been published to extension, then providing the solution could have taken much longer time due to the publish process. So as you were using web version and reported the issue before it is being published to extension, I was able to provide quick fix for this. Hence I would request you continue to use the Web version. If you face any issues, you can switch back any time.

shridhar-tl commented on Sep 02, 2022

@NeoMatrixJR - I have tried to reproduce this issue with latest version of Vivaldi and it appears the issue is already resolved and is working fine now. So I would suggest you to try using it with latest version of Vivaldi if you are still wanting for using JA with Vivaldi.

I will try to ensure JA works with Vivaldi as well from next release onwards, but it is really difficult to check each and every functionality for all the browsers like Chrome, Edge, Firefox, Vivaldi and again Web version for all these browsers. Hence I depend on users to report the issue with all the required details when raising the issue.

You can also try using the Web version of JA in Vivaldi by accessing https://app.jiraassistant.com. If you have the extension already installed, then Web version would connect with extension and would work well.

As this issue is resolved, closing this issue. Please feel free to reopen it or raise a new issue if you face any other issues.