Jira Assistant Issues

View #244 on GitHub to know more details

#244 - Unable to fetch the data of issue work log in jira assistant plugin day wise for one particular issue.

Saicharan-idexcel commented on Dec 27, 2022

Unable to fetch the data of issue work log in jira assistant plugin day wise for one particular issue.

shridhar-tl commented on Nov 24, 2022

@Saicharan-idexcel - Please look at the suggestion provided in #242. Though issue looks different, I believe the root cause is same. Please try the same solution and let me know if it solves your issue.

gzarinac commented on Nov 25, 2022

@Saicharan-idexcel, I have the same issue with the Jira cloud but "The most recent version of JIRA Cloud is no longer using the traditional indexing method, and as such, the option to trigger a re-index has been removed." Any suggestions?

NateFort commented on Nov 27, 2022

@Saicharan-idexcel reindexing is no longer an option. I also get the following when trying to do a Worklog Report image

shridhar-tl commented on Nov 30, 2022

Hi, I did not realize you are using Cloud version of JIRA. Of course if I had known you are using cloud, I wouldn't have suggested this option.

So far no one else has reported such issue with cloud version. So I do not have any clue at this point. Thank you for including the console log. But for this use case network log could be more useful. Will you be able to send the screenshot of network log particularly with response code and if possible response data partially visible.

Please ensure you do not expose any sensitive information in screenshot as this is a public forum.

shridhar-tl commented on Dec 12, 2022

I heard from a different user in #242 that they have too many worklogs in that issue and that is the reason they were not able to pull it. See if you have something related to that. Not just Worklogs, look at comments and change history as well. if there are 1000's of entry, then that could be one of the possible cause.

gzarinac commented on Dec 15, 2022

A colleague of mine said that Atlassian recently implemented paging on Jira API and that you should implement it to enable the correct fetching of worklog calendar data. I hope this will help.

shridhar-tl commented on Dec 15, 2022

Hi @gzarinac, paging was there since too many years and already tool is capable of pulling data from multiple pages for both issues and for worklog. How ever let me check if there is something changing in API anyway and get back on this by this weekend.

gzarinac commented on Dec 16, 2022

@shridhar-tl great, thnx. If you need any additional information or I can help somehow, please let me know.

shridhar-tl commented on Dec 18, 2022

Hi @gzarinac , you are right. Pagination was missing in worklog API call. Though I know worklog data were paged, I somehow did not have the implementation done on that. I still haven't added pagination, but had added additional filters so that worklog count should get reduced based on latest options available in worklog api.

This fix is only available in Web as of now. You can try it from web version and let me know if this issue has been resolved: https://app.jiraassistant.com

gzarinac commented on Dec 19, 2022

Hi @shridhar-tl, I try from the web version, and my worklog is empty, with no entries at all. Also, the worklog in version 2.43 is empty too, and version 2.42 show partial data.

shridhar-tl commented on Dec 20, 2022

Hi @gzarinac, the usual question, do you see any console errors now? and currently where are you checking? from calendar or from worklog report or from dashboard gadget?

Please mail me the details and I would be able to provide additional details / support to resolve this issue.

gzarinac commented on Dec 20, 2022

Hi @shridhar-tl, I use Worklog Calendar from the browser extension, and it shows partial data. I tried from Jira Assistant Web a few minutes ago, and It works now. I can see all my calendar entries again.

shridhar-tl commented on Dec 20, 2022

Hi @gzarinac , that's good to know. So recent fixes would always be available in Web. It would take some time to publish updates to extension due to the time taking review process in web store. So I cannot push the updates very frequently and it would at least take 1 more week for you to see the fix in extension. Till then I would request you to use the web version.

From extension, by clicking the "Switch to Web" option from top right corner of the page. So that whenever you try to open a page using JA icon in browser, it would automatically open web instead, and you can avoid manually opening it every time.

If you are interested, you can permanently use Web version so that if you face any issue in future, you can intimate it immediately and avoid the bug being published to extension and wait for time consuming process for fix.

shridhar-tl commented on Dec 20, 2022

@NateFort and @Saicharan-idexcel - Hoping your issue is also resolved. Please let me know if you are still facing any issues.

shridhar-tl commented on Dec 27, 2022

This implementation is done and hence closing this issue. This change is already available in Web version and you would start seeing the changes in Extension and Cloud App once you are updated to JA v2.44.